Forum Discussion

PratikshaMehete's avatar
Occasional Contributor
5 years ago

Unable to connect database in ready api

Hello all,


I have reset my database password from SQL developer. Now from ready api i entered new password in database configuration.  I am not able to establish the connection. Below error occured


Unable to get a connection for the specified properties: java.sql.SQLRecoverableException: IO Error: The Network Adapter could not establish the connection

  • Hi All,


    Issue is resolved. I tried resetting the database password again. While setting new password i didnt not use the special character. then tried giving updated password in database configuration and it worked :-)

    Its strange and hard to digest the solution but my issue is resolved :-)

36 Replies

  • richie's avatar
    Community Hero

    Hi PratikshaMehete 


    yeah - this non-helpful response occurs occasionally when you can't connect to your Oracle RDBMS.


    if you've changed the password youre using to connect to the Oracle user/schema with - the error response sounds about right.


    I'd recreate the RDBMS connection with the updated password - but before that - have you double checked you can access the database with the new password using SQLDeveloper?


    I'd double check you can hit the database with teh new password via SQLDeveloper and as long as you can - I'd just create a new DB connection with the new password - then repoint any of your JDBC steps that connect to that DB to use your newly created connection.






    • PratikshaMehete's avatar
      Occasional Contributor



      thanks for reply,


      I checked i am able to connect the DB using new password in SQL Developer

    • PratikshaMehete's avatar
      Occasional Contributor

      I recreated the RDBMS connection with the updated password still i am getting the same error

      • HimanshuTayal's avatar
        Community Hero

        could you share any image/screenshot for the error that you are getting, so that it will be more clear what's the issue

    • PratikshaMehete's avatar
      Occasional Contributor



      yes i am able to connect DB with new password in SQL Developer.

  • Have you tried registering your driver manager if not please try the following:


    DriverManager.registerDriver( new oracle.jdbc.driver.OracleDriver());


      • sdeevers's avatar

        I believe HimanshuTayal gave you the cirrect info to register the driver;

        DriverManager.registerDriver( new oracle.jdbc.driver.OracleDriver());


        However, you may also want to check your environment to be sure you are using the correct Oracle driver. You can get the applicable Oracle packagehere, Saved the driver package in the "C:\Program Files\SmartBear\ReadyAPI-3.0.0\bin\ext" directory for the connection to be established. As a side note, when you upgrade to another version of Ready API you will need to move the oracle file to the new release directory.


        Hope this helps you get the problem resolved.


  • If you are using environments, check / update if necessary the value associated in the "JDBC Connections" tab for your environment.

    • PratikshaMehete's avatar
      Occasional Contributor

      Hi , I checked "JDBC Connections" tab for environment. when i test connection i get error. 

      • nmrao's avatar
        Champion Level 3
        Do you have the same issue connecting to this DB using other machines / client softwares other than ReadyAPI?