Forum Discussion

jal90's avatar
jal90
New Contributor
4 months ago

Support for java 17 using SoapUI-maven-plugin.

Hi! Can you please tell me how could it be possible to use SoapUI-maven-plugin with java 17? I would like to use it on Jenkins, and I cannot install java 16 in Jenkins... because it runs on AWS and all my other tests (Selenium) are running on Java 17.  While I tried in maven to use maven-compiler-plugin with release version 16, it throws an error that a groovy script cannot be run because of unsupported class file major version 61. On my local SoapUI works as expected with java 17, but the soap plugin no.

2 Replies

  • lxdv163's avatar
    lxdv163
    New Contributor

    Hi, friends

    I met the same issue with you, have you resolved the issue? I see no more reply