Forum Discussion

smcmickle's avatar
12 years ago

Able to find objects, but not use them!

Hello again!

Here is my issue:: I can find objects in the object browser, I can highlight the objects via Name Mapping, but when running the script, the objects are coming up not found! 

I can literally record a script test, then attempt to replay it, yet I get errors stating something like::

"Unable to find the object ClickItem("Admin"). See Additional Information for details."

Thanks for the help!



7 Replies

  • sastowe's avatar
    Super Contributor
    In the opbject browser, look up the tree a bit. Look for any case in which the object(s) that contain your children objects might have the same name in the same node of the tree. If that is the case, you need to use some mechanism for identifying WHICH of the objects with the same name contains the object you want. I use name mapping with extra seach. I forget the name of the property. You can also look at the various Find methods.
  • Thanks Stephanie for the reply, I shall go ahead and try that. I will get back soon!
  • Doesn't appear as if that is the issue. I don't have any parents of the same name. I can go to the object browser and right click the child node and click "highlight on screen" and it will say the object is not visible, despite when I use the object spy, that is the object it had JUST found... 

  • Here was the solution::

    Tools:: Current Project Properties:: Object Mapping:: Switch all the items that you are using to Derived Classes.

    This was due to us using custom objects. We would make TreeTables as opposed to tables or trees.
  • Seems this caused something that worked before to no longer work! Hmmm..... At first buttons didn't work and tabs worked, now it is the reverse.
  • Ended up reinstalling TC, using my co-workers settings. Finally ended up working!! I am so happy!! I can finally start to get some awesome automated testing going! Thanks everyone for helping! :-)