Forum Discussion

shenyusun's avatar
shenyusun
Contributor
7 years ago

TestComplete Jenkins Plugin - GUI test, TestComplete did not launch it.

Hello Community,

 

I tired to integrate TestComplete project with Jenkins, but somehow TestComplete won't launch when Jenkins started to build.

I was thinking maybe because "Silent' mode was passed as argument? If so, how do I modify it so it won't be silent mode.

 

My setup:

1. Jenkins slave running as service mode.

2. TestComplete 11

3. Jenkins console log is hanging at this screen:

14:30:08 [TestComplete] Found TestComplete/TestExecute installations:
14:30:08 	Type: TC, Version: 11.31.2420.7, Path: "C:\Program Files\SmartBear\TestComplete 11\bin\TestComplete.exe"
14:30:08 [TestComplete] Selected TestComplete/TestExecute installation:
14:30:08 	Type: TC, Version: 11.31.2420.7, Path: "C:\Program Files\SmartBear\TestComplete 11\bin\TestComplete.exe"
14:30:08 [TestComplete] [WARNING] The node is connected via Java Web Start (JNLP). In this mode, the "Run interactive user session" property of the TestComplete Test step is ignored. TestComplete (or TestExecute) will work in the current user session.
14:30:08 [TestComplete] Launching the test runner.
14:30:08 $ "C:\Program Files\SmartBear\TestComplete 11\bin\TestComplete.exe" "c:\jenkins\workspace\SmokeTest\SmokeTest.pjs" /run /SilentMode /ForceConversion /ns /exit "/ExportLog:c:\jenkins\workspace\SmokeTest\1808641.tclogx" "/ExportLog:c:\jenkins\workspace\1808641.htmlx" "/ErrorLog:c:\jenkins\workspace\1808641.txt" "/ExportLog:c:\jenkins\workspace\SmokeTest\1808641.mht" "/project: SmokeTest_Basic"

 

4. Jenkins configuration(See attachment)

 

 

Any help/suggestion would be helpful!

 

Thank you!

 

  • Support resolved the issue.

     

    The Jenkins Service needs to run by Local account.

15 Replies

  • Marsha_R's avatar
    Marsha_R
    Champion Level 3

    If you go out to a prompt and run this command manually, does it work?

     

    C:\Program Files\SmartBear\TestComplete 11\bin\TestComplete.exe" "c:\jenkins\workspace\SmokeTest\SmokeTest.pjs" /run /SilentMode /ForceConversion /ns /exit "/ExportLog:c:\jenkins\workspace\SmokeTest\1808641.tclogx" "/ExportLog:c:\jenkins\workspace\1808641.htmlx" "/ErrorLog:c:\jenkins\workspace\1808641.txt" "/ExportLog:c:\jenkins\workspace\SmokeTest\1808641.mht" "/project: SmokeTest_Basic"
    • shenyusun's avatar
      shenyusun
      Contributor

      Hi Marsha,

       

      Thank you for your help.

       

      Yes, it worked if I typed the command manually. TestComplete launched, and then start doing UI tests.

      I guess /SilentMode wasn't the issue.

       

      • shenyusun's avatar
        shenyusun
        Contributor

        Somehow when Jenkins passed that to slave, TestComplete won't launch, but I can see TestComplete process stated, but usage didn't move that much.

  • shankar_r's avatar
    shankar_r
    Community Hero

    My setup:

    1. Jenkins slave running as service mode.

    2. TestComplete 11

    3. Jenkins console log is hanging at this screen: - This is will be hangs up in the same line until the run completes. Once the run completed you will presented something like with below lines

    [TestComplete] Test runner exit code: 2.
    [TestComplete] [WARNING] Errors occurred during the test execution.
    [TestComplete] Marking the build as UNSTABLE.
    [TestComplete] The test execution finished (Automation_Framework).
    Build step 'TestComplete Test' changed build result to UNSTABLE